Our web-based Capistrano

Improve collaboration within your team.
Hosted, secure and available any time, from anywhere.

Try it now! No thanks


Capistrano is bundled as a Ruby Gem. It requires Ruby 1.9.3 or newer.

Capistrano can be installed as a standalone Gem, or bundled into your application.

It is recommended to fix the version number when using Capistrano, and is therefore recommended to use an appropriate bundler.

General Usage

The following command will install the latest released capistrano v3 revision:

$ gem install capistrano

Or grab the bleeding edge head from:

$ git clone
$ cd capistrano
$ gem build *.gemspec
$ gem install *.gem

Usage in a Rails project

Add the following lines to the Gemfile:

group :development do
  gem 'capistrano-rails', '~> 1.1.1'

The capistrano-rails gem includes extras specifically designed for Ruby on Rails, specifically:

  • Asset Pipeline Support
  • Database Migration Support

The documentation for these components can be found in their, respective, READMEs. However for the most part, to get the best, and most sensible results, simply require in Capfile, after the require 'capistrano/deploy' line:

require 'capistrano/rails'
Help! I was using Capistrano v2.x and I didn't want to upgrade!

If you are using Capistrano v2.x.x and have also installed Capistrano v3 by mistake, then you can lock your Gem version for Capistrano at something like:

gem 'capistrano', '~> 2.15' # Or whatever patch release you are using

This is the pessimistic operator which installs the closest matching version, at the time of writing this would install 2.15.4, and any other point-release in the 2.15.x family without the risk of accidentally upgrading to v3.


Fork me on GitHub